CVE-2019-13503 (mongoose)

mq_parse_http in mongoose.c in Mongoose 6.15 has a heap-based buffer over-read.
Source: NIST
CVE-2019-13503 (mongoose)